[Chimera-users] Principal axis of inertia

Elaine Meng meng at cgl.ucsf.edu
Thu May 14 09:02:49 PDT 2009

Hi Armida,
I just tried the script in Chimera 1.3 and in a recent daily build  
(1.4) and it worked in both.

I'm guessing that when you tried it, Chimera did not know the file  
type of the script because it was not named ending with ".py".  If you  
look at the link below, even though the mail program names the file  
"attachment.ksh", the original name is "inertiapdb.py".  You could  
name it that or actually anything that ends in .py and then it should  

For example, I saved the script file to my Desktop and named it  
inertiapdb.py.  Then I started Chimera, then opened a PDB file, then  
used "File... Open" in the menu to open inertiapdb.py -- an ellipsoid  
is shown in the Chimera window and numerical information is shown in  
the Reply Log.

I hope this helps,
Elaine C. Meng, Ph.D.                          meng at cgl.ucsf.edu
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
Department of Pharmaceutical Chemistry
University of California, San Francisco

On May 14, 2009, at 6:42 AM, A. Di Fenza wrote:

> Hi Tom,
> I saw your message on the web and I tried to use your script on  
> Chimera 1.3.
> Unfortunately it does not work, it give me the following message:
> 0 models opened
> Do you think it is because of the Chimera version? Do you have  
> suggestion?
> Thank you very much,
> Armida
> Oops.  That script I posted for calculating the inertia of a molecule
> had some problems.  The printed matrix of axes was transposed though  
> the
> correct axes were used for the displayed ellipsoid.  Also I was using
> inertia matrix I_ij = sum_over_k(m_k*r_ki*r_kj) omitting the diagonal
> term.  Should have been I_ij = sum_over_k(m_k*(|r_k| - r_ki*r_kj)).   
> And
> finally I incorrectly computed the ellipsoid size along each axis.
> Everything was a little bit wrong.  Here's the fixed version.   
> Tested in
> Chimera version 1.2500 but should work with earlier versions.
>    Tom
> -------------- next part --------------
> An embedded and charset-unspecified text was scrubbed...
> Name: inertiapdb.py
> Url: http://www.cgl.ucsf.edu/pipermail/chimera-users/attachments/20080321/21f01cdf/attachment.ksh

More information about the Chimera-users mailing list