[Chimera-users] Fwd: Chimera - remote start up issue

Greg Couch gregc at cgl.ucsf.edu
Mon May 24 11:12:27 PDT 2021

tl;dr -- VirtualGL worked.

-------- Forwarded Message --------
Subject: 	Re: [Chimera-users] Chimera - remote start up issue
Date: 	Mon, 24 May 2021 13:16:18 +0000
From: 	Filip Kadlec <Filip.Kadlec at vutbr.cz>
To: 	Greg Couch <gregc at cgl.ucsf.edu>

Good evening,

I'm writing to you with feedback since I remembered you wanted to let 
know if any of the methods worked. I got to it a bit later than expected 
(sorry for the delay) and let me tell you it was painful indeed. However 
the final solution was with VirtualGL with Cygwin combination - 
Installed Cygwin with all tools needef for X11 forwarding, server... 
including the VirtualGL client. On server installed VirtualGL server. 
Then using XLaunch (cygwin provides) and setting the right $DISPLAY 
variable it is possible to run and quite smoothly operate with 
visualisation programs (vglconnect, vglrun). Chimera, ChimeraX and also 
PyMOL works just fine.

Thank you for the previous help and advice, it pointed me in this 
direction! Have a great day.

Kind regards
*Od:* Greg Couch <gregc at cgl.ucsf.edu>
*Odesláno:* pátek 7. května 2021 20:35
*Komu:* Kadlec Filip (191426) <Filip.Kadlec at vutbr.cz>; 
chimera-users at cgl.ucsf.edu <chimera-users at cgl.ucsf.edu>
*Předmět:* Re: [Chimera-users] Chimera - remote start up issue

Yes, as you discovered, remotely displaying 3D graphics is 
problematic.   Sometimes it works, usually if the graphics driver on the 
remote computer and the local computer are the same (same manufacturer, 
same operating system, i.e., same variant of Linux and version).

In your case, I'd recommend installing the VirtualGL package on the 
CentOS 7 computer, along with a graphics card and its driver.  That way 
the 3D graphics are done on the CentOS 7 computer and an image is sent 
to your computer.  VirtualGL is available from the epel repository and 
virtualgl.org.  This is also the solution for nomachine and x2go.

An alternative would be to try the free cygwin.org X11 server, or a 
commercial X11 server, like Exceed 3D.  If either of those work, please 
let us know.

     Good luck,


On 5/7/2021 4:28 AM, Filip Kadlec wrote:
> Good afternoon!
> I haven't found a solution to this problem in one of your user 
> threads, internet and I haven't succeeded resolving the issue.
> I have installed chimera 1.15 today and it runs well when working on 
> the desktop. However, it would be very convenient if I could run 
> chimera remotely. Chimera is installed on Centos 7, I am trying to 
> remotely operate this PC with Windows 10 PC using MobaXterm. When I 
> run chimera as /chimera --debug/:
> initializing general preferences
> loading Tix
> initializing graphics
> create application
> loading Pmw
> creating main window
> creating menus
> creating toolbar
> creating viewer
> initializing OpenGL
> X Error of failed request:  GLXBadCurrentWindow
>   Major opcode of failed request:  146 (GLX)
>   Minor opcode of failed request:  5 (X_GLXMakeCurrent)
>   Serial number of failed request:  2711
>   Current serial number in output stream:  2711
> With OpenGL on Centos-7 PC /glxinfo | grep "OpenGL":/
> OpenGL vendor string: Mesa Project
> OpenGL renderer string: Software Rasterizer
> OpenGL version string: 1.4 (2.1 Mesa 10.5.4)
> OpenGL extensions:
> Have you encountered such problem? Could the problem be with coliding 
> OpenGLs, or graphical transfer through mobaxterm? It would be a major 
> help if you could point me in the right direction.
> Thank you in advance and have a great day!
> Kind regards
> Filip Kadlec
> _______________________________________________
> Chimera-users mailing list:Chimera-users at cgl.ucsf.edu  <mailto:Chimera-users at cgl.ucsf.edu>
> Manage subscription:https://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users  <https://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20210524/690a6c14/attachment.html>

More information about the Chimera-users mailing list