[Chimera-users] labels turned white

Oleksiy Kovtun okovtun at mrc-lmb.cam.ac.uk
Thu Nov 9 10:14:48 PST 2017


Hi Elaine, 
thank you a lot for looking at the problem. Sorry I forgot to attach the files, sending them now. I now suspect the problem is connected to my system. I updated Chimera to the 1.12, same story with default white colour for labels even if I open a brand new session.

Best wishes, 
Oleksiy

 



On 9 November 2017 at 17:42:26, Elaine Meng (meng at cgl.ucsf.edu) wrote:

Hi Oleksiy,  
I could not reproduce this problem… although you didn’t attach files, I just put the label-file lines you gave into a text file (it was also necessary to add a tab before each line except for the first), then:  

used 2D Labels dialog, File menu to read the label file  
entered the two 2dlabels commands given in your message  

.. see attached image for result. I also attached the label file. Tested in 1.12 release and in current daily build, both on Mac, so it is still possible there is something different with your system. You could try the label file I attached to see if it makes any difference.  

I hope this helps,  
Elaine  
----------  
Elaine C. Meng, Ph.D.  
UCSF Chimera(X) team  
Department of Pharmaceutical Chemistry  
University of California, San Francisco  



> On Nov 9, 2017, at 6:25 AM, Oleksiy Kovtun <okovtun at mrc-lmb.cam.ac.uk> wrote:  
>  
> Dear community,  
> I encountered a problem with 2D labels turning white disregards what colour presets I give.  
>  
> The script reads title presets from a file (2dlabel path) and then display the title with these commnads:  
>  
> 2dlabels change * bgColor 1,1,1,0.75;  
>  
> 2dlabels change title visibility show  
>  
> The 'title' label should appear as opaque black font as defined in the label file:  
>  
> Label title  
> (x,y): (0.18,0.5)  
> text: u'Title'  
> shown: False  
> font size(s): 40  
> font style(s): bold  
> font typeface(s): sans serif  
> color(s): (0, 0, 0, 1)  
>  
> But it appears in white. Bizarrely all other presets in the label file translate into the title appearance as they should except for the colour.  
>  
> I run Chimera 1.11.12 (build 41280) on Unix.  
> Script and label file are attached.  
> Thank you.  
> Oleksiy  

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20171109/dada9f76/attachment-0001.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: labels.txt
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20171109/dada9f76/attachment-0002.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: script.txt
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20171109/dada9f76/attachment-0003.txt>


More information about the Chimera-users mailing list