[Chimera-users] split ligands and H-bonds

Markus Heller mheller at cdrd.ca
Wed Nov 16 12:50:57 PST 2016


Thanks Elaine,

For the explanation as well as the solutions!  I knew it could be done somehow :)

Markus

-----Original Message-----
From: Elaine Meng [mailto:meng at cgl.ucsf.edu] 
Sent: Wednesday, November 16, 2016 9:57 AM
To: Markus Heller
Cc: chimera-users at cgl.ucsf.edu BB
Subject: Re: [Chimera-users] split ligands and H-bonds

Hi Markus,
Short answer #1 is that you do not need to split to use different stick thickness.  You could just change individual bond radii instead of the model stick scale:

open 3t07
setattr b radius 0.5 ligand

All bonds initially have radius 0.2.

Answer #2 requires a little more explanation. Although there is an intermodel setting, the GUI FindHBond doesn't look between submodels with the same main model number.  Normally, this is something like an NMR ensemble and people would be confused by the detection of hbonds between different ensemble members that were right on top of each other.

The split command happens to make submodels although maybe it should have made separate main model numbers instead.  

However, "findhbond" command has an interSubmodel option to get around this.  E.g. in 3t07 after the split, you could do something like

select ::09c
hb selRestrict any intersub t reveal t log t

(note two colons before residue name that starts with a number) ...only finds one H-bond:  #0.3 09C 586.B N3  #0.1 SER 362.A OG

I hope this helps,
Elaine
-----
Elaine C. Meng, Ph.D.                       
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab Department of Pharmaceutical Chemistry University of California, San Francisco

On Nov 15, 2016, at 3:57 PM, Markus Heller <mheller at cdrd.ca> wrote:

> Hi,
> I have a structure of a complex (I tried with several, but here's one example: 3t07).  I want the stick radii for protein and ligand to be different, so I "split ligands" and then set the stick scale in the attributes of the respective model.
> 
> When I then try to detect H-bonds between the ligand and the protein, none are found!  They are found, however, when detecting them prior to splitting the model with "split ligands".
> 
> I've tried several settings in the Find Hbond dialog:
> 
> Find inter-model, intra-model, both: no difference.
> 
> Restrict to the models the H-bonds are between: no difference.
> 
> Select the ligand and the protein residue participating in the H bonds and using "Only find H bonds with both ends selected": nothing, no H bonds found.
> 
> Why is that?
> 
> Thanks and Cheers
> Markus




More information about the Chimera-users mailing list