[Chimera-users] Module import error

Greg Couch gregc at cgl.ucsf.edu
Mon Jun 20 15:05:05 PDT 2016


(I assume you meant --nostatus)

For me the simple test of a file with:
> import os
> os.system("chimera --nogui --nostatus")
works just fine.  So it's probably something about your particular setup 
that is tickling this bug.

It might be the directory that you're running the script in, it might 
have python modules/packages that conflict with chimera's.  Or it might 
something in the environment.  Chimera tries to protect its python from 
the user's environment, but maybe we missed something. Also double check 
that the chimera you're invoking is the one you're expecting -- try 
using an absolute path to chimera while you're debugging this.

     HTH,

     Greg

On 06/20/2016 01:18 PM, Subha Kalyaanamoorthy wrote:
> Hi There,
>
> I am trying to call a script with Chimera commands(saved as sample.py 
> file)  in another python program using os.system("chimera --nogui 
> --nostats sample.py") and I get an module load error as below,
>
> import chimera
>
> ImportError: No module named chimera
>
>
> However, if I call the script with chimera it works, for eg., chimera 
> --nogui --nostats sample.py typed directly in terminal is working.
>
>
> Can anybody help fix this error?
>
>
> Thanks in advance,
>
> Best Regards,
>
> Subha
>
>
>
>
> _______________________________________________
> Chimera-users mailing list: Chimera-users at cgl.ucsf.edu
> Manage subscription: http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20160620/3240b151/attachment-0001.html>


More information about the Chimera-users mailing list