[Chimera-users] Non-alphanumeric character in keyword

MPI mpi566 at gmail.com
Tue Oct 27 08:51:32 PDT 2015


Dear  Eric and Elaine,

 Thanks for the solution.

It works but one of result files ( say, mytest.pdbqt  if mytest is
prefix) will NOT come out  if  the command of vina   is provided in a
script instead of GUI.

I guess  that the main output ( mytest.pdbqt) will directly be given
into viewdock  in GUI mode and  it will be saved but not in a script.

I wonder if  there is a way to save the main output (mytest.pdbqt)  in
a script so that I can view the result of mytest.pdbqt later.


Thanks,
Dwey











On 10/26/15, Eric Pettersen <pett at cgl.ucsf.edu> wrote:
> The file to be modified is <your Chimera
> installation>/share/Midas/midas_text.py.  Here’s the diff:
>
> @@ -3352,9 +3353,9 @@
>                 except:
>                         raise MidasError, "No value provided for keyword
> '%s'" \
>                                                                         %
> typed
> -               if not keyword.isalnum():
> -                       raise MidasError, "Non-alphanumeric character in" \
> -                               " keyword '%s'" % keyword
> +               if not keyword.replace('_', '').isalnum():
> +                       raise MidasError, "Non-alphanumeric or underscore "
> \
> +                               " character in keyword '%s'" % keyword
>                 if keyword[0].isdigit():
>                         raise MidasError, "Leading digit in keyword '%s'" %
> (
>
> keyword)
>
> —Eric
>
> 	Eric Pettersen
> 	UCSF Computer Graphics Lab
>
>
>> On Oct 26, 2015, at 6:43 PM, MPI <mpi566 at gmail.com> wrote:
>>
>> Dear Elaine,
>>
>> Thanks for your kind help !    Would you please let me know which
>> file is to be modified  in old ver. if a single file is responsible
>> for that keywords  ?  because I have mulitple manchines.   I'll
>> download a daily build and update that modifiled file if this would
>> work.
>>
>> Regards,
>> Dwey
>>
>> On 10/26/15, Elaine Meng <meng at cgl.ucsf.edu> wrote:
>>> Dear Dwey,
>>> Sorry about that — it was a bug that keywords with underscores in them
>>> did
>>> not work.
>>>
>>> You can get the fix in the next successful daily build (probably
>>> tomorrow).
>>> Check for daily build dated Oct 22, 2015 or later:
>>> <http://www.rbvi.ucsf.edu/chimera/download.html#daily>
>>>
>>> Thanks for reporting the problem!
>>> Elaine
>>> ----------
>>> Elaine C. Meng, Ph.D.
>>> UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
>>> Department of Pharmaceutical Chemistry
>>> University of California, San Francisco
>>>
>>>
>>>> On Oct 25, 2015, at 7:38 AM, MPI <mpi566 at gmail.com> wrote:
>>>>
>>>> Dear users,
>>>>  In Chimera, I tried to run a vina docking in command line like
>>>>
>>>> vina docking receptor #0 ligand #1 output mytest search_center 10,20,30
>>>>
>>>> There is an error:
>>>>
>>>> Non-alphanumeric character in keyword 'search_center'
>>>>
>>>> I have tried tweaking  the keyword 'search_center' in  different ways
>>>> but  the error won't go.
>>>>
>>>> Dose anyone know how to fix it ? or is this format correct ?
>>>> Many thanks,
>>>> Dwey
>>>
>>>
>>
>> _______________________________________________
>> Chimera-users mailing list
>> Chimera-users at cgl.ucsf.edu
>> http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users
>>
>
>



More information about the Chimera-users mailing list