[Chimera-users] help with surface coloring

Elaine Meng meng at cgl.ucsf.edu
Wed May 7 10:54:06 PDT 2014


Hi Christian,
Not a stupid question, because there is a color hierarchy that can be confusing: model color, atom colors, and per-atom-patch surface colors that may differ from the actual atom colors, with each sucessive level of assignment obscuring the previous level.  For example, if there are no per-atom assignments, you would just see the model color.
<http://www.rbvi.ucsf.edu/chimera/docs/UsersGuide/hierarchy.html>

However, what you describe should be unusual, because (as far as I know) it means that you specifically assigned the third level, which is not easy to do by accident.  Normally if you just open a structure and color subsets of the atoms, then show a surface, the surface will match those atoms.  For example, commands:

open 1zik
color yellow :.a
color cyan :.b
surface

...would show the surfaces of the A and B chains as yellow and cyan. (Same result if you selected via Sequence and then used Actions... Color to apply the coloring and "surface main" in the Model Panel.) You definitely want the molecular surface's color source to be "atoms", but it should be that way by default.  Also, make sure that the Color Actions are set to the default behavior of coloring all the representations (menu: Actions.. Color... all options, and in the resulting dialog make sure that "Coloring applies to" "all of the above").

Unfortunately, once you are in the state you described, I don't know of a way to remove just that last level of coloring assignments so that the surface matches the atoms.  As far as I know you would have to re-select and do the coloring again, after verifying that Color Actions will apply to surfaces as well as atoms.

Also, it's possible I misinterpreted the situation, but it was the only explanation I could come up with.
I hope this helps,
Elaine
-----
Elaine C. Meng, Ph.D.                       
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
Department of Pharmaceutical Chemistry
University of California, San Francisco

On May 7, 2014, at 9:36 AM, Benda, Christian wrote:

> Hello, 
> sorry for a possibly stupid question but I seem to have a problem getting a molecular surface colored the same way as the atoms or ribbons of the underlying structure. Here’s what I did:
> 
> - selected two domains of a larger protein separately (sequence viewer) and colored each domain differently (say green and blue, ribbons and atoms are in the respective color)
> - then selected the molecule in the model panel and clicked surface main
> - I get a surface, but it is either transparent grey or a solid color (pink) of the color well displayed in the model panel (not the domain colors I selected).
> - when opening the attributes of the surface, I can toggle between color source “atoms" or “model" but that only toggles between transparent gray and pink.  
> 
> I tried all kinds of combinations and clicks but I don’t manage to get the surface colored in the colors of the two domains.
> 
> Any hint? It would be highly appreciated!
> Many thanks!
> Christian




More information about the Chimera-users mailing list