[Chimera-users] Chimera hardware resources

Tom Goddard goddard at sonic.net
Tue Feb 18 10:00:30 PST 2014


Hi Derrick,

  For large data files you should use 64-bit Chimera.  If you use 32-bit Chimera it can access at most 4 Gbytes of memory.  Chimera caches volume data, and the default cache size is 0.5 Gbytes.  To increase this go to the Volume Viewer dialog menu Features / Data Display Options and change the "Data cache size (Mbytes)" field to say 16000 to allow using 16 Gbytes.  You may need to press the Return key after typing the new value in that field.  The menu entry Features / Save Default Dialog Settings can let you save this cache size so the next time you start Chimera you do not need to change it again.

  Hopefully the above 2 suggestions remedy your problem.  I recorded an animation in Chimera a few weeks ago with 6000 frames including slicing through a 15 Gbyte optical microscopy map of the human brain with 4096 by 4096 image output and did not have any trouble with excessive memory use (on a Mac with 32 Gb and Geforce GTX 680MX with 2 Gb).  For showing slices of a map it is better to use the "volume planes" command instead of clip planes.  It will look better and be less memory intensive.  For example

	volume #0 planes z,0,1000

will flip through planes 0 to 1000 perpendicular to the data z axis.

	http://www.cgl.ucsf.edu/chimera/docs/UsersGuide/midas/volume.html#planes

  Tom


On Feb 17, 2014, at 1:48 PM, Derrick Smith wrote:

> Hi Chimera users,
> 
> I've been working with what are probably some pretty big files (400 MB - 3 GB) for ultramicrotomed sections of holograms. I've trimmed the volume down as well as I can while keeping it large enough to see what we ultimately were aiming for. However, I am running into some hardware resource issues. None of our computers in the lab can handle it, so I've been using my gaming rig at home to do it. I run a server off it also, so have some decent hardware to work with, but I cannot figure out how to reallocate the resources that Chimera seems to default to.
> 
> I have 64 GB of system RAM available, and after recording 1-2 movies of rotations or a flythrough of clippings etc. Chimera has never used more than 1.5 GB. My graphics card has 4 GB. After filtering and post-processing, before any rotation or video capturing, the vid card has used around 2 GB already. During video capture, depending on if I'm rotating or clipping (clipping uses up a lot more faster), the vid card memory slowly gets eaten up, eventually crashing Chimera altogether. I can usually only get about 800-1000 frames before this happens on a smaller file (400 MB), and usually can't get through a whole 10s, or 250 framed, video on one of the larger files.
> 
> I have pretty limited experience with this program, so I'm hoping it's a simple settings or otherwise fix I've overlooked. Any suggestions on this?
> 
> Best,
> Derrick
> -- 
> Derrick Smith
> Drexel University
> Soft Materials Group
> 
> Philadelphia PA 19104
> _______________________________________________
> Chimera-users mailing list
> Chimera-users at cgl.ucsf.edu
> http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users




More information about the Chimera-users mailing list