[Chimera-users] running chimera 1.8 needs root privilege

Greg Couch gregc at cgl.ucsf.edu
Tue Jul 16 11:58:24 PDT 2013


Hi Bob,

If it works as root, but not as a normal user, then there are two likely 
possibilites: (a) they are using different OpenGL libraries (libGL.so), 
or (b) a file/device permissions problem.  And double check that your 
DISPLAY environment variable is ":0".  Also note that most issues are 
solved by installing the proprietary AMD or NVIDIA graphics driver 
(using the Additional Drivers dialog), so if you aren't, do that first.  
My condolences if you have Intel graphics -- in that case I'd recommend 
updating to Ubuntu 13.04 (or newer), the Intel Linux graphics driver is 
under heavy development and the newer versions are much better.

A quick test, run glxinfo (from the mesa-utils package), both as root 
and as yourself.  They should be the same, if not, then the differences 
are a big clue.

To test the OpenGL library hypothesis, run (CHIMERA is the path to the 
Chimera installation):

     env LD_LIBRARY_PATH=CHIMERA/lib ldd CHIMERA/lib/_chimera.so

both as root and as yourself.  If they are not the same, figure out 
why.  If they are the same, then check the permissions on every shared 
library listed.

     Please let me know what you try and if it fixes the bug,

     Greg

On 07/16/2013 07:13 AM, Robert Wohlhueter wrote:
> I've been using Chimera 1.5.3 under Linux (Ubuntu 12.04, 64-bit) 
> without problems; that version I had installedas root, andis owned by 
> root.  Just now I updated to version 1.8, which, initially, I also 
> installed as root. But trying to run it (as non-root) gave me fairly 
> opaque error messages(copied below). On a hunch that it was a matter 
> of privilege, I tried running with `sudo` -- which works fine.
>
> Since it was not obvious where the problem lay, I cleaned out the 
> installation, and installed anew as a normal user (me).  Accordingly, 
> the whole installation directory tree is owned by me.  But still I 
> cannot run it (same errors) as me, but only with `sudo`. Same user, 
> same start directory, apparently the same Python (2.7) as works with 
> v. 1.5.3.
>
> I'm totally flummoxed!  Can't imagine where the privilege hang-up is. 
> Any hints where I should look?
>
> Thanks,
>
> Bob Wohlhueter
>
> *****************************C-shell output*******************
> chimera
> X Error of failed request: BadRequest (invalid request code or no such 
> operation)
> Major opcode of failed request:  128 (GLX)
> Minor opcode of failed request: 198 ()
> Serial number of failed request:  2813
> Currentserial number in output stream:  2813

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20130716/a32622c9/attachment-0001.html>


More information about the Chimera-users mailing list