[Chimera-users] questions about modeller and task panel

Elaine Meng meng at cgl.ucsf.edu
Tue Feb 19 09:43:56 PST 2013


Hi Susan,
When I run Modeller calculations via Chimera and open the Task Manager, there is a "Cancel" button on the far right, and clicking it aborts the job.

However, in your case it might be confused and think the job is running when it has actually already failed due to the installation problem.  From the error message, it does really appear to be an installation problem, not where to put the output. The bottom of the traceback just says the output file doesn't exist.

You could try running using the web service instead of your local installation, and in that case the Cancel button on Task Manager should function because the job is actually running.

As for the installation problem, I don't know what to say, because I have that same version of Modeller installed on my Mac and have not had any problems running it locally.  I just ran the automatic installer and did what it told me to do.  However, I am specifying the Modeller binary as  
/Library/modeller-9.11/bin/mod9.11
NOT
> /Library/modeller-9.11/bin/mod9.11_mac10v4
as shown in your traceback.  You might try using the former instead and seeing if that helps.  If not, I can only say to ask the Modeller help about the installation problem.

I hope this helps,
Elaine
----------
Elaine C. Meng, Ph.D. 
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
Department of Pharmaceutical Chemistry
University of California, San Francisco

On Feb 17, 2013, at 2:43 PM, Smith, Susan Margaret Ellen wrote:

> Hello,
> I am trying to use Chimera as an interface to a local installation of Modeller on my Mac.
> 
> I have two questions:
> 1) When I open the task panel, I can see the current tasks and the completed tasks (nice visual cuing), but I do not see any way to kill a job.  How can I select a job and how can I stop it?
> 
> 2) When I run the tutorial example for Modeller, I get the following message, which seems like it is telling me that something is wrong (although the job appears to still be running in the task panel).  I have re-installed the Modeller package, but I don't know what 'environment variable' was not set ... It seems like the program doesn't know where to put the output, although I specified a path for the temporary output.  Can you help with this?
> 
> Thanks,
> Susan
> 
> Target seq: oprd_human
> Template structures:
>        4DKL (#0)Run locally, the Modeller binary location: /Library/modeller-9.11/bin/mod9.11_mac10v4
> Now, modeller is running locally...
> MODELLER process output
> -----------------------
> FATAL ERROR: MODINSTALL9v11 environment variable not set: incomplete MODELLER installation
> -----------------------
> MODELLER process errors
> -----------------------
> -----------------------
> Traceback (most recent call last):
>  File "/Applications/Chimera.app/Contents/Resources/share/chimera/tasks.py", line 179, in runStatusCB
>    task.statusCBList[0]()
>  File "/Applications/Chimera.app/Contents/Resources/share/chimera/SubprocessMonitor.py", line 166, in statusCB
>    self.finished()
>  File "/Applications/Chimera.app/Contents/Resources/share/chimera/SubprocessMonitor.py", line 201, in finished
>    self._after(self._aborted)
>  File "/Applications/Chimera.app/Contents/Resources/share/MultAlignViewer/ModellerBase.py", line 635, in _collectResultsCB
>    OKModels = self._showingOKmodels(self.pathTemp)
>  File "/Applications/Chimera.app/Contents/Resources/share/MultAlignViewer/ModellerBase.py", line 646, in _showingOKmodels
>    modelsInfoFile = osOpen(os.path.join(outputPath, "ok_models.dat"))
>  File "/Applications/Chimera.app/Contents/Resources/share/OpenSave/__init__.py", line 324, in osOpen
>    raise UserError(val)
> UserError: [Errno 2] No such file or directory: '/Users/dlambe/Desktop/ok_models.dat'
> 




More information about the Chimera-users mailing list