[Chimera-users] morph map and movie recording

Elaine Meng meng at cgl.ucsf.edu
Thu Apr 25 16:42:09 PDT 2013


Hi Moumita,
Our expert in this topic is not here (will be back next week), but in the meantime I will try to guess what is happening and give some hints.

The "vop morph" command creates a new map, by default assigning it the lowest unused model number. 
<http://www.cgl.ucsf.edu/chimera/docs/UsersGuide/midas/vop.html#morph>

I'm guessing the problem is that you set threshold and used hide dust for the input maps before using "vop morph", but unfortunately those settings do not apply to the new map.

WIth the Morph  Map graphical interface, you can first create the morph map, then use Hide Dust to hide the dust in the new map and Volume Viewer to adjust its threshold (or corresponding commands "sop hideDust" and "volume" with the "level" option), and then go back to the Morph Map Interface and "Play" and/or "Record" that existing map without re-creating it.  However, the "vop morph" command is all-in-one and creates the map right before playing it, so there is no opportunity to change the new map's settings and hide its dust in between.  Unfortunately I don't know how to solve that problem.  In other words, I don't know how to separate creation of the morph map and playback of the morph in a command script, so that you could control its threshold and dust display with other commands in between.  I'm hoping our expert will be able to suggest something when he returns.

The part about the input maps displaying and orientations changing makes no sense to me, other than you may be using their model numbers (or no model numbers) instead of just the model number of the new map in subsequent commands in the script.  By default the "vop morph" command should hide the input maps (hideOriginalMaps true).

Best,
Elaine
----------
Elaine C. Meng, Ph.D. 
UCSF Computer Graphics Lab (Chimera team) and Babbitt Lab
Department of Pharmaceutical Chemistry
University of California, San Francisco

On Apr 25, 2013, at 4:07 PM, "Moumita Dutta" <dutta at bio.fsu.edu> wrote:

> Hello,
> I am trying to morph more than two maps at a time so I am using vop morph instead of Morph map. I am following the mini-video animation example script of vop morph using the recommended chimera 1.7 version 2013. The script actually recorded the movie but in the movie threshold changed from what I set and it turned some maps to x 90 degree not all and it is not showing the morph animation only the superimposed maps. Another problem is though I remove the dust after loading the maps but it came back in the morph and in the movie as well.
> How can I fix the problems and generate the movie ?
> Moumita




More information about the Chimera-users mailing list