[Chimera-users] [Dock-fans] Help with antechamber

Eric Pettersen pett at cgl.ucsf.edu
Wed Feb 29 16:08:22 PST 2012

This previous posting to the dock-fans list seems to be more directly  



                         Eric Pettersen
                         UCSF Computer Graphics Lab

On Feb 29, 2012, at 2:47 PM, Trent E. Balius wrote:

> Hi Brad,
> I am cc'ing this to the chimera list.
> I think that you should write a python script to run DOCK prep on  
> the command line.  See the following:
> http://www.cgl.ucsf.edu/pipermail/chimera-dev/2011/000784.html
> For other example scripts see the following:
> http://www.cgl.ucsf.edu/pipermail/chimera-users/2009-February/003539.html
> You should not have to specify the AMBERHOME path.  This is done  
> internally to chimera.
> as an aside, It is unnecessary to run antichamber with sudo.
> I hope this helps,
> Trent E. Balius
> Graduate Student, Rizzo Group,
> Department of Applied Mathematics and Statistics,
> Stony Brook University.
> Office: Math Tower 3-129, Phone: (631) 632-8519
> URL: http://www.ams.sunysb.edu/~tbalius/
> -----Original Message-----
> From: Brad Ridder <clustro at gmail.com>
> To: dock-fans <dock-fans at docking.org>
> Sent: Wed, Feb 29, 2012 4:38 pm
> Subject: [Dock-fans] Help with antechamber
> Hi Dockfans,
> My name is Brad; I am a grad student in the dept. of chemical  
> engineering at Purdue University.
> We are experimenting with DOCK for various drug discovery work. At  
> the moment, I am trying to do execute all of the "dock prep"  
> commands through the Terminal, since it is not practical to do large  
> volumes of Dock Prep by hand through the CHIMERA GUI.
> Corresponding to what is in the DOCK tutorial, I am on "Receptor and  
> Ligand Preparation." I got reduce to work, in order to add hydrogens.
> Now, I am trying to get antechamber to work, in order to add the  
> charges, but it is not working. Here is the command I am running:
> sudo ./antechamber -i $DESKTOP/3GLR.pdb -fi pdb -o $DESKTOP/ 
> 3GLRcharged.mol2 -fo mol2
> Which returns the error:
> Warning: $AMBERHOME and $DOCK_HOME enviornment strings are not set,  
> use "mopac.sh" in the work directory
> Cannot open CONNECT.TPL , exit
> The atom number exceeds the MAXATOM, reallocate memory
> I looked around in the dock6 directory, and found a folder called  
> "parameters/antechamber", which contains CONNECT.TPL. I figured this  
> is what should be the $AMBERHOME directory.
> For DOCK_HOME, I figured it should be the dock6 folder.
> Here is what I have in my .bash_profile file in my home folder.
> export AMBERHOME='/home/.../DOCK6.5/dock6/parameters/antechamber'
> export DOCK_HOME='/home/.../DOCK6.5/dock6'
> I also tried using the "amber11" folder that comes with CHIMERA as  
> AMBERHOME, but to no effect.
> I don't actually have AMBER installed on my computer, but since  
> CHIMERA can add charges without actually requiring the purchase of  
> AMBER, I do not think that is the problem.
> I did not know what to do with "mopac.sh." I ran the script, but it  
> says it needs input files.
> What am I doing wrong that is preventing antechamber from executing  
> correctly?
> -- 
> Bradley James Ridder
> Chakrabarti Group
> Graduate Student
> School of Chemical Engineering
> Purdue University
> _______________________________________________
> Dock-fans mailing list
> Dock-fans at docking.org
> http://mailman.docking.org/mailman/listinfo/dock-fans
> _______________________________________________
> Chimera-users mailing list
> Chimera-users at cgl.ucsf.edu
> http://plato.cgl.ucsf.edu/mailman/listinfo/chimera-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://plato.cgl.ucsf.edu/pipermail/chimera-users/attachments/20120229/33b78a43/attachment.html>

More information about the Chimera-users mailing list