[Chimera-users] Space Navigator on Linux

Thomas Goddard goddard at cgl.ucsf.edu
Thu Apr 15 19:31:15 PDT 2010

Hi Daniel,

   I tested the Space Navigator with Linux Chimera (1.4.1 and 1.5 daily 
builds) and like you found it didn't work.  The trouble was that a linux 
space navigator library (libspnav.so.0.1) was accidentally left out of 
the Chimera distribution.  I've fixed that and it should be in the daily 
builds tomorrow.

   Adding that it still didn't work!  I found that it requires 
spacenavd, an open source alternative to the 3dconnexion driver 
(3dconnexion makes the Space Navigator device).


Chimera does not include, nor start that daemon.  If you get spacenavd, 
install it and start it, tomorrow's Chimera daily build should work with 
the Space Navigator.

   I thought the Space Navigator support in Linux Chimera worked with 
the 3dconnexion driver but searching my old email I see I never tested 
it because the 3dconnexion driver required some old Motif libraries that 
I couldn't find.  Now I've tried it and it is clear Chimera will not 
work with the 3dconnexion driver.  We will need to document this in the 
Chimera manual.  Some more work could probably make Space Navigator work 
with the 3dconnexion driver on Linux but that part of the Chimera code 
was written by someone outside the lab (Thomas Margraf) and it is not 
too likely we will be able to fix it given our many other priorities.


> Dear all,
> I am trying to use a 3DConexion SpaceNavigator with chimera in my linux
> machine. I have installed the SpaceNavigator drivers and they work
> properly with the manufacturer test tools (xcube and xvalue). Althought
> I am running the last chimera release, when I open chimera it does not
> "see" the device. Should I do something special when I start chimera or
> once it is open in order to use the device?
> Thanks in advance,
> Daniel

More information about the Chimera-users mailing list