[Chimera-users] chimera on linux machines

Tom Goddard goddard at cgl.ucsf.edu
Wed Nov 12 20:23:07 PST 2008

Hi Irene,

  Almost all Chimera crashes are caused by graphics driver bugs.  These 
are especially common on older machines and on laptops.  They are common 
on linux when no graphics driver has been installed or only an ancient 
driver is installed.  Perhaps 10-25% of systems exhibit some graphics 
driver problems, some of those causing crashes, and some incorrect 
images.  We give Chimera hands-on classes and I would consider it 
suicidal to not test all the material on the classroom machines before 
hand.  We have a web page devoted to graphics driver bugs:


The suggested fix is to update your graphics driver.  Generally linux 
systems have no card-specific graphics driver installed unless you the 
user get one from Nvidia or ATI and install it.  Without one a library 
called Mesa is used and we have encountered many bugs with it.  Though I 
haven't seen the exact error you report.  Greg Couch in our lab may be 
familiar with that specific error.


Irene Newhouse wrote:
> I've installed chimera on Windows boxes & had no problems whatsoever.
> Imagine my shock when, at a workshop, I had the attendees using it
> on a linux box for the first time, and as soon as they tried to work with
> the view control window, using the getting started tutorial, chimera
> crashed. Oddly, when I had them load a pdb file & use the symmetry data
> to fill out the unit cell, that worked just fine. Needless to say, 
> things were
> way too hectic to pursue at that point.
> Now that the dust has settled, I've tried chimera on my own linux 
> workstation
> [a nearly new Dell 64-bit machine, on which I put the 32-bit version] 
> with gobs
> of memory & Red Hat linux version 5], I was able to use the view control
> window with 1zik.pdb as described in the tutorial, which had not been 
> true on
> the other machines, which are older & smaller,  but when I was trying out
> rotation, zoom, & translation with the mouse, chimera suddenly crashed 
> - all its
> windows vanished from the monitor in a flash. I got the following 
> error message:
> X Error of failed request:  BadValue (integer parameter out of range 
> for operation)
>   Major opcode of failed request:  91 (X_QueryColors)
>   Value in failed request:  0xff000000
>   Serial number of failed request:  23745
>   Current serial number in output stream:  23745
> What can I do about this?
> Thanks!
> Irene Newhouse

More information about the Chimera-users mailing list